Home Assistant falando na ALEXA (TTS)

Fala Moçada!

Abaixo segue um fluxo simples e muito útil para quem tem a Alexa integrada com o Home Assistant.

Para que a Alexa fale alguma coisa, basta seguir os detalhes abaixo:
image

O “segredo” está no conteúdo do campo DATA:

O importante é focar nas duas partes destacadas em amarelo acima pois a primeira é a MENSAGEM que a ALEXA vai ler (o title é irrelevante neste caso) e a segunda é o NOME do seu DISPOSITIVO ALEXA.

{
    "data": {
        "type": "announce",
        "method": "all"
    },
    "title": "TESTE ALEXA",
    "message": "<voice name=''>Teste da Alexa falando pelo Home Assistant</voice>",
    "target": [
        "media_player.echo_dot"
    ]
}

Abraços,
José Henrique.

2 Curtidas

Parabéns, showwwwwwwwwwwww

1 Curtida

Show de bola! Parabéns!

1 Curtida

Instalei a Alexa media player, porém não encontro ela do Nodered, alguém poderia me ajudar a configurar, fiquei a noite toda tentando e sem sucesso.

Olá Bruno.

Reinicie o NODE-RED pelo Add-On que deve aparecer.

Abraço,
José Henrique.

Obrigado pela dica, tentarei quando chegar em casa, aí posto aqui se resolveu!
:+1::grin:

Deu certo, agora está funcionando! muito obrigado! :grin:
Me tira uma outra dúvida por favor, eu consigo perguntar coisas do Home Assistant para Alexa?
Por exemplo: "Alexa, onde está Bruno? e ela responderia: “Bruno está em casa!”
Ou ate mesmo perguntar a velocidade da internet no Speedtest.

oi Bruno!

Pesquise no Fórum que fizeram um Artigo sobre isso.

Abraço,
José Henrique.

Blz, vou dar uma olhadinha,

Muito Obrigado

Abraço,
Bruno Rodrigues.

Henrique? Ele tá dando “Call-service API error. Error Message: Service not found.” Qual é a configuração necessária?

Olá,

Provavelmente o conteúdo do campo DATA está inválido. Cole-o aqui para que possamos analisar.

Abraço,
José Henrique.

Mas é o mesmo que você colocou lá em cima (tentei alterando apenas a descrição do meu Echo Dot:

{
"data": {
    "type": "announce",
    "method": "all"
},
"title": "TESTE ALEXA",
"message": "<voice name=''>Teste da Alexa falando pelo Home Assistant</voice>",
"target": [
    "media_player.echo_dot"
]

}

Você está com o Media Player configurado corretamente?

Sim, no meu caso fiz o processo com NabuCasa e o teste e a ativação da skill ocorreram normalmente.

Pluga um node DEBUG no TOMADA PIA e veja o que sai nele.

No DEBUG executa normal, ele desliga a tomada, mas no CALL SERVICE da Alexa, dá essa mensagem:
“Call-service API error. Error Message: Service not found.”

Fiz um teste pelo HA e olha o que deu:

Estranho hein! Parece que o seu media player não está legal.

Obrigado!! Como faço para ela ler o meu sensor?