Tasmota - Sonoff Zbbridge - Timed out waiting for packet header

Senhores,

Estou tentando colocar Tasmota em um Sonoff Zbbridge, mas o processo para no erro acima.

Vi que se trata de um problema recorrente em diversas placas ESP 8266 e 32, mas não achei nada referente a essa placa.

Tentei PCs diferentes, Windows 10 e Windows 7, diferentes portas, e dois comversores seriais com chips diferentes.

Tentei também alimentar o Sonoff com fonte independente, mantendo os GNDs interligados.

Tentei também dois Sonoffs diferentes, ambos novos, e nada.

Queria saber dos senhores se já tiveram experiência no assunto.

Grato

Os mcu esp8266 e esp32 precisam de ser bootados de um modo especial para receber um firware novo, se eu não me engano o pino GPIO0 precisa estar puxado para baixo ou seja voce precisa dar um curto entre GND e GPIO0 com a placa desligada ai enegrizar a placa e depois tirar o curto.Ai voce pode remover o jumper que esta fazendo esse curto e fazer uplaod do firmware.

1 Like

O que o Ariel citou é muito importante.

Outro fator que pode atrapalhar é o contato na placa do zbbridge. No meu caso só resolvi quando “limei” as pontas dos jumpers que iam na placa. Depois de garantir um bom contato consegui colocar o Tasmota sem problemas. Antes tive vários problemas (erros), mas, como não anotei, não posso comparar com o erro que está ocorrendo com você.

1 Like

Agradeço seus comentários.

Tanto o GPIO0 está no GND, e foi desligado após a placa iniciar. O led verde, que está ligado nesse pino, acende, o que prova estar correta a ligação ao GND.

Não usei pinos nos furos, mas soldei diretamente cabos aos pontos de GND, GPIO0, TX, RX (invertidos), e 3V3.

Algumas pessoas colocam um capacitor de 10uF entre os pinos enable e gnd (polo negativo no gnd) e dizem que resolve. Mas todos meus esps que começaram a dar esse problema até hoje não consegui resolver nehum.