Problemas com https

Pessoal eu consegui configurar o duckdns mas só funciona por http://dominio por https não e preciso que funcione para poder configurar o google assistant como Home assistant sem o uso do nabucasa, alguém pode me ajudar? Sobre as portas eu jáo configurei no roteador pra quando receber na 443 direcionar para o ip do hA local na porta 443 tb, acho q o problema esta em alguma configura;cao dentro do ha pois se coloco od direcionamento da 443 pra 8123 funciona mas sem o https,aguardo alguma ideia

Olá, @GustavoMartins!!

Veja se o Config do DuckDns está assim…

Abraço,
José Henrique.

Aqui em casa não tive mais problemas com https depois de instalar o Nginx Proxy Manager

Poderia passar como configurar ele, eu não entendi muito bem.

Instala em add-ons, tem o tutorial: https://github.com/hassio-addons/addon-nginx-proxy-manager/blob/v0.2.1/README.md

esta igualzinho, ainda não consegui resolver:thinking:

tentei tb nãpo deu certo, uma dúvida que tenho no roteador eu coloco a porta 443 direcionada pro Ip onde esta instalado o hass mas direciono pra porta 443 do has ou pra 8123?

Com o nginx direciona porta 443 para 443 e 80 para 80 do IP que está o Home Assistant.

Pessoal obrigado consegui fazer funcionar!!!

Boa noite pessoal, finalmente consegui ajustar, graças aos amigos que sempre estão ajudando… deixo aqui um feedback, pois isso eu acho importante, sempre agradecer.

Obrigado.
Wesley

boa tarde.
Sou usuario da rede da vivo, ainda com aparelhos da GVT, nao consigo fazer procedimento, já adicionei as portas, mas não consigo fazer o acesso, alguem mais passou por isso?

Atualmente uso net, mas antes era vivo e havia configurado o redirecionamento das portas tanto com modem da GVT como o mais novo deles…

Bom dia Paulo, vou te passar o que eu fiz e deu certo…

Meu modem tb é o da GVT Power Box, fiz esse procedimento nele… liberei as 3 portas e o destino é o ip do HA.

Depois na configurações do Duck fiz isso… coloquei o token e o dominio d duck.

Fiz a instalação do Nginx Proxy Manager e segui o exemplo da propria page deles.

e para finalizar no arquivo configuration.yaml

coloquei esse trecho.

image

Espero que de certo.

Wesley

obrigado pela atenção.

Não sei, se é por motivo de utilizar outro roteador, após o powerbox da gvt, mas nao consigo passar da parte do Nginx Proxy Manager, qual crio o proxy e deste tenho o acesso.
Sempre dá erro, de que não é possivel acessar o site.

Alguma sugestão??

@wesleyrodrigoo, consegui avançar mais um pouco.
Sou relativamente lento, pois não sou da área de informática.

Conseguir liberar a porta do modem e fazer o acesso externo, utilizando o app do homeassistant ou pelo site, mesmo.

Porém não consigo deixar a conexão segura.

Tentei utilizar aquelas linhas de comando no final de sua mensagem, porém, meio que deu pau e o serviço não subia. Após retirar as linhas no configuration.yaml, tudo voltou como era.

Alguma sugestão?

Paulo, esse erro que pode estar acontecendo nao é de tabulação ? colocou fora do padrão ?

Wesley

até pode ser, adicionei as linhas e tive esse retorno

Só pra constar, estou trabalhando com o sistema rodando em um ubuntu server

Meu caro, não sei o que houve com o meu Nginx eu consegui acesso via “open web ui”, quando configurei pela primeira vez. Mas depois de instalado não conseguia mais conectar direto pelo IP do meu HA e nem pelo hassio.local:8123. Conecto sem problemas direto pelo meudominio.duckdns.org:8123 então nunca mais mexi. Hoje tentando configurar um tablet no APP da Ariela notei que deva um erro de certificado, tentei também pelo HomeHabit é o mesmo problema com certificado. Olhei toda minha configuraçã do Duckdns aparente tudo normal. Ai passei para o Nginx, removi para reinstalar. Feito, mas agora não consigo entrar. Poderia dá uma daquelas suas dicas de ouro!?

Olá @MrPontes!

O meu NGINX está na versão 3.0 e está com a configuração abaixo:

Abraços,
José Henrique.

Minha configuração estava quase igual, somente a linha 5 que não havia. Coloquei, mas ainda tenho problemas. Observei que a porta 81 de acesso ao Nginx eu havia removido do meu router, coloquei de volta consigo entrar novamente. Mas quando fazer a configuração do host seguindo o tutorial oficial ele abre uma nova aba no navegador com essa informação:

Parabéns!
Você iniciou com êxito o Nginx Proxy Manager.
Se você está vendo este site, está tentando acessar um host que ainda não está configurado.
Faça login no painel do administrador para começar.