Dificuldades para gravar o firmware no ESPHome

Bom dia a todos!

Depois de muito tempo usando tasmota precisei usar o ESPHome e para minha surpresa esta aparecendo um erro informando que é necessario o uso de HTTPS para criar o firmware e subir no ESP8266.
Encotrei varios artigos sobre essa questão, porém não ficou claro pra mim qual executar pois cada um informa situações diferentes.
A última vez que utilizei o ESPHome isso não era necessario.
Fico grato por qualquer informação, obrigado!

Pelo que entendo, a segunda opção que vc mencionou ali é apenas se voce tem aquele plano da Nabu Casa, onde eles ofererem um acesso externo ao teu HA. No meu caso, eu só consigo usar esta opção se me logar pelo acesso externo.

Quando estou localmente, uso a terceira opção ali mesmo. Se tua instancia do HA tiver instalada no raspberry basta apenas conectar nele. Ou via Virtual Box, tem que configurar o acesso a porta USB antes de startar a maquina virtual.

Faz um tempo que nao utlilizo esphome também. Porém pelo jeito que está escrito no print parece que essa segunda opção seria pra conectar o esp via USB no computador onde você está abrindo a interface do ha. E a terceira que é a que já tinha antes é no USB do computador aonde está instalado o HA, essa era opção que já existia e que não precisa de HTTPS.

Boa noite!

É isso mesmo, como já não acessava a interface a muito tempo acabei não acompanhando as mudancas…
Fiz como o “marcelouff” falou e como eu fazia (so que não me lembrava), baixei o bin manualmente e subi no ESP pelo ESPHome-Flasher, agora qualquer update faço pelo OTA.
Obrigado a todos pela disponibilidade, suporte e ajuda!

1 Like